Author Topic: Inkscape only prints at 96 dpi by default?  (Read 2625 times)

September 01, 2017, 09:12:51 PM
Read 2625 times

maisieinforestburg

  • Jr. Member

  • Offline
  • ***

  • 27
Hey I'm wanting to make some 8 x 10 files to be printed at 300 dpi, but it seems I only get the option to print at 96 dpi....

I was told by someone to make the file 2400 x 3000 pixels, and I would get the proper resolution, but when I save that as a pdf, I'm getting in the properties that it would print out at 26.67 x 33.33 inches ...........
so how would one make printables at 8x10" and 300 dpi?

Thanks!

September 02, 2017, 01:12:15 AM
Reply #1

Lazur

  • IC Mentor

  • Offline
  • ******
  • Inkscape Filters Wizard

  • 1,107
  • Gender
    Male

    Male
Hi.

If you save as pdf, any further dpi calculation is irrelevant for the general size.
Set up the page borders of your document to the desired print physical units, and every vector content will be present as vectors inside
=the print resolution will only depend on the printer, and won't be limited by the document.
Only exceptions are the filters which in general are not supported by the pdf format so the save as pdf dialog asks for a rasterizing resolution at which raster doubles are generated to substitute the filtered parts.

But if you really want a raster format instead -keep in mind inkscape works at 96 dpi. If you want a given output size with an embedded resolution data, you need to scale down your image before exporting by 96/300=32%, after that your exporting at 300 dpi should match exactly the same pixel values in the png's size.

If the image doesn't use too much filtering I'd suggest printing from pdf-s.
(Just for the note layer blending modes and blurring are filtering too.)

September 02, 2017, 04:14:50 AM
Reply #2

brynn

  • Administrator

  • Online
  • ******

  • 3,607
  • Gender
    Female

    Female
    • Inkscape Community
Welcome to the forum!

I'm not very good with printing issues.  I started to answer this message, then I got distracted with something else.  And meanwhile, Lazur has posted.  His information is likely more proper than mine.  But I'll go ahead and post anyway, in case it helps.

From what I've heard (and observed), Inkscape doesn't have very sophisticated printing support.  Often I read that some people recommend saving as PDF, and using PDF printing options.

Although having said that, when I click Print from the Inkscape window, I get a print dialog with 2 tabs.  The first tab is General, where you can choose which kind of printer to use, and some other options.  The other tab, called Rendering, gives 2 choices - Vector and Bitmap.  If I choose Bitmap, a DPI spinbox becomes activated.  This is with version 0.92.2.

As far as I know, to do what you want, you could export a PNG at 300 DPI, and then print to the particular size that you need.  (Inkscape doesn't offer to print at a certain size.  I'm guessing if you have a printer connected to the computer, it will give you the option.  But I don't have a printer connected, so I'm not positive.

Which version of Inkscape are you using?  If it's an older version, then it sounds like you could either upgrade, or at least temporarily install the current stable version (to see these same options as I see in the Print dialog.
  • Inkscape version 0.92.3
  • Windows 7 Pro, 64-bit
Inkscape Tutorials (and manuals)                      Inkscape Community Gallery                        Inkscape for Cutting Design                     



"Be ashamed to die until you have won some victory for humanity" - Horace Mann                       

September 02, 2017, 02:36:24 PM
Reply #3

flamingolady

  • IC Mentor

  • Offline
  • ******
  • Flamingo Lady

  • 74
  • Gender
    Female

    Female
I also get a 'rendering' tab that appears when printing.  You do need to click on the 'rendering' tab and choose the proper choice (vector). 

Lazur is the math whiz for sure, (Brynn is following closely behind).  But yes, 96 is the default you need to get the page to print out at 100% the size you drew it at, but that option only appears when you export as a png file.  I'm not clear if you are exporting as a png first or printing a vector/svg directly from inkscape?   DPI is what the printer needs, and vectors don't use that, it's all confusing I know.

As an example, I just printed a vector that I wanted to fit on the US standard letter size, which is 8.5" X 11.0", so, I went to doc properties and set the page size to letter (2nd choice there), or set to custom sizes.  I assume you've already done that.  Then to get the printer to print it at 100%, I only had to click on print, then choose 'vector' on the rendering tab.

If you Export as a Png, then leave as 96 dpi to get it to show and print at your 100% (which is exactly what you drew).