Author Topic: Re: New user question re: break apart/ungroup  (Read 3831 times)

August 16, 2018, 10:38:32 AM
Reply #25

octoolguy

  • Jr. Member

  • Offline
  • ***

  • 19
Thanks Lazur and Brynn. That cleaned up drawing is going to be helpful. Brynn, I'll give that a try and see if it helps.

Ray
  • 0.92
  • windows 10

August 16, 2018, 12:36:54 PM
Reply #26

octoolguy

  • Jr. Member

  • Offline
  • ***

  • 19
Why am I getting this gray area? It doesn't show up until I close the node pen tool with the double click. I have tried messing around with all the "tool" preferences but nothing seems to change.
  • 0.92
  • windows 10

August 16, 2018, 01:59:52 PM
Reply #27

Moini

  • IC Mentor

  • Offline
  • ******

  • 1,566
    • VektorRascheln
remove the fill, instead add a stroke.

August 16, 2018, 02:16:37 PM
Reply #28

octoolguy

  • Jr. Member

  • Offline
  • ***

  • 19
Can you give me some point by point instructions on how to do that? I have tried everything but can't get the fill/stroke to work or change from the default. Thanks for your help.
  • 0.92
  • windows 10

August 17, 2018, 06:23:34 PM
Reply #29

Moini

  • IC Mentor

  • Offline
  • ******

  • 1,566
    • VektorRascheln
Right-click on the fill field in the left bottom corner, select 'swap fill and stroke'.

August 17, 2018, 06:24:41 PM
Reply #30

Moini

  • IC Mentor

  • Offline
  • ******

  • 1,566
    • VektorRascheln
With the objects selected, of course.

August 18, 2018, 07:41:11 AM
Reply #31

brynn

  • Administrator

  • Offline
  • ******

  • 3,937
  • Gender
    Female

    Female
    • Inkscape Community
Actually I'm not sure if removing the fill is what you need to do.  It looks like you are drawing with an LPE applied to the paths.  I would suggest to just delete those, and start over.  (You don't have to start over, but it's probably easier.)

This time when you start, when the Pen tool is enabled and you're ready to go, look at the control bar.  Here's a screenshot below.  Click on it to make it bigger.  Sorry for the weird theme color I have.  It's easy on my old eyes.

In the red rectangle is what's called the control bar.  It has different options on it, depending on which tool is enabled.  Try switching tools, and watch the options change.  That's how you can configure the various tools to work how you want them too.  There are other ways to configure the tools, but those are the most commonly used settings.

The screenshot is showing the Pen tool control bar.  I put a blue circle around the dropdown menu which you need to set to None.
  • Inkscape version 0.92.3
  • Windows 7 Pro, 64-bit
Inkscape Tutorials (and manuals)                      Inkscape Community Gallery                        Inkscape for Cutting Design                     



"Be ashamed to die until you have won some victory for humanity" - Horace Mann                       

August 18, 2018, 11:32:55 AM
Reply #32

octoolguy

  • Jr. Member

  • Offline
  • ***

  • 19
Moini, once again, thanks. I tried fooling around with the fill/stroke and managed to get the drawing to respond. What I did find is that when I followed Tyler's directions in his gif, he specified to put the trace below the top layer. So, I have been doing it that way. Just for the heck of it, I tried putting it above the top layer and all of a sudden, I have something that I can work with. I think the reason I was getting the weird gray area was because it was below the top layer. I still get that intermittent red line when I drag my cursor over the trace layer after doing the node editor. I haven't figured out how to get rid of that yet.

Brynn, thanks to you also. I did check the node pen settings as you suggested and mine was set on "none".

Also, is there a way to set my preferences so that nothing I do in a previous work session comes back on my next session? It seems that when I use the zoom tool, it immediately goes way bigger that it should and I know that I saw on a video somewhere that you can do a "reset" of all the tools so that you are starting clean. I tried to find that but couldn't locate it.

Thanks again to you all for you kindness and for bearing with me. I know I'm asking a lot but at my age, I just don't grasp it like you younger folks. Once I get it though, I'll take it to my grave. It's all starting to sink in. Bit by bit.


  • 0.92
  • windows 10

August 18, 2018, 12:26:28 PM
Reply #33

brynn

  • Administrator

  • Offline
  • ******

  • 3,937
  • Gender
    Female

    Female
    • Inkscape Community
I think at this point, we'd have to look at your SVG file, to figure out why this or that is happening.  One thing that I've seen a lot, as well as experienced myself, when I was first learning.  I remember clicking on anything and everything I could find, which I thought might help, but which I didn't necessarily know what it was or does, in trying to make things work.  And eventually the file is full of objects (which sometimes might or might not be completely visible) which are behaving in strange ways, and options are enabled or disabled, creating strange behavior.

Sometimes it's a good idea, after one or more learning sessions, is to open a fresh new file, and start the project new.  Or maybe copy the drawing into a fresh new file, in case you've gotten a lot of work done.

I'm not sure why tylerdurden suggested putting the drawing on an upper layer, locking it, and drawing on a lower layer.  Usually it's the other way around, where it's a lower layer which holds the imported image and is locked, and you draw on an upper layer.  But that weird gray area is not caused by the layer arrangement.  It's from when, at some point, you were drawing with the Shape option on the control bar set to Triangle In or Triangle Out.  That object apparently never was deleted, and you managed to select it and fill it with gray.  Possibly when you switched the layers around, you hid the layer which the gray object is on, so that you just don't see it anymore.  As I said before, I just can't guess what's happening on your canvas by now.  I'd have to look at the SVG file.

I gave instructions to disable that red line that flashes when  you mouse over a path.  Here they are again:

Edit menu > Inkscape Preferences > Tools > Node

Uncheck "Always show outline".

If you did that, and it's still flashing, there might be other boxes to uncheck.  Attached is a screenshot of my Node tool preferences.  Using those options  you will not see the red flashing line anymore.

Also, is there a way to set my preferences so that nothing I do in a previous work session comes back on my next session? It seems that when I use the zoom tool, it immediately goes way bigger that it should and I know that I saw on a video somewhere that you can do a "reset" of all the tools so that you are starting clean. I tried to find that but couldn't locate it

This isn't a video, but you might have seen this technique in a video:  https://forum.inkscapecommunity.com/index.php?action=articles;sa=view;article=15 

That technique would not involve the zoom tool though.  Are you talking about when you open the file for the first time since your last session, and it opens  being already zoomed in?  That would happen if either you closed the file while it was still zoomed in, or you had a crash while the file was zoomed in.  However, if the file does open being zoomed in, you can easily set it back to normal by pressing the "1" key once.  That automatically sets the zoom to 100%.

More zoom controls:  The " ` " key (which is on the left of the "1" key for me) takes you back to the previous zoom, whatever it was.  And Shift + ` takes you forward in your zoom levels.
  • Inkscape version 0.92.3
  • Windows 7 Pro, 64-bit
Inkscape Tutorials (and manuals)                      Inkscape Community Gallery                        Inkscape for Cutting Design                     



"Be ashamed to die until you have won some victory for humanity" - Horace Mann                       

August 18, 2018, 12:51:13 PM
Reply #34

octoolguy

  • Jr. Member

  • Offline
  • ***

  • 19
Brynn, I did check that "node" setting when you first told me to and it was already unchecked. I guess that wasn't the problem. I actually went so far as to uninstall Inkscape and then go out and get a fresh download and install it from there. The problems I'm having seem to be either a computer problem or something that I'm self-inflicting. I have found that a lot of the problems have gone away since I put the trace layer up on top. Thanks again.
  • 0.92
  • windows 10

August 19, 2018, 12:53:57 PM
Reply #35

brynn

  • Administrator

  • Offline
  • ******

  • 3,937
  • Gender
    Female

    Female
    • Inkscape Community
If you put the settings like I showed in my last screenshot, you should not be seeing that flashing red line at all.  If your settings are just like mine, and you still see it sometimes, I'm not sure where it might be coming from. 

If you know how to make a video, you could show us what it looks like.  That might help us figure it out.

Otherwise, we'll just look forward to seeing your masterpiece  :-D
  • Inkscape version 0.92.3
  • Windows 7 Pro, 64-bit
Inkscape Tutorials (and manuals)                      Inkscape Community Gallery                        Inkscape for Cutting Design                     



"Be ashamed to die until you have won some victory for humanity" - Horace Mann                       

August 19, 2018, 03:08:03 PM
Reply #36

octoolguy

  • Jr. Member

  • Offline
  • ***

  • 19
I went back in to preferences>node and set all the settings exactly as you show in your screen shot. I have no idea how to make a video here on the computer but it this doesn't work out, I want to thank you for all your efforts to help me. I'll let you know if it works.

Ray
  • 0.92
  • windows 10