gotcha

Author Topic: Floating nodes  (Read 41 times)

September 15, 2018, 12:51:36 PM
Read 41 times

lindamac1158

  • Sr. Newbie

  • Offline
  • **

  • 2
I'm using Inkscape 92.3. When ever I try to move nodes, it looks like they are floating with no line following. I've tried to set the nodes in Preferences with no luck. Also I get a lot of "cusp nodes to cusp nodes" which is driving me crazy. I've tried to figure this out using the inkscape manual but it is all Greek to me. Can you direct me on how to set the Preferences to avoid these two issues. Thanks! I've been using Inkscape for years but only started having this issue since upgrading to 92.3
  • 92.3
  • Windows 10

September 15, 2018, 03:56:15 PM
Reply #1

brynn

  • Administrator

  • Offline
  • ******

  • 2,930
  • Gender
    Female

    Female
    • Inkscape Community
Welcome to the forum!

If you don't see the path connected to a node when you drag it, that could be happening as part of performance issues.  Do you see this behavior in a new blank file?  Or does it only happen  in very, very large files (say over 1 mb)?  Do you have any other performance issue, such as slowness or freezing?

Just to make sure you have the right settings in Inkscape Preferences, go to Inkscape Preferences > Tools > Node and make sure "Update paths when dragging nodes" is checked.

Are you using that path outline feature (the annoying red line which flashes when the mouse goes over the path)?  If so, you'll also want to check "Update outline when dragging nodes".

Or if you're a new user, I guess it's possible that part of the path is hidden under another object.  Or that you're dragging the node underneath another object, so the path can't be seen.  It could happen with any color of object, but if you have an object the same color as the background, you might not remember it's there.

To make sure the object you're dragging is on top of everything else, select it with Selection tool and click Object menu > Raise to top (or this button on the control bar  :mtt: ).  Or if you're using Layers, in the Layers menu, click the tiny eye icon, to hide the upper layers.

I can't think of anything else to explain the path not showing, right now.  If none of that helps, you might consider sharing your SVG file, and telling us exactly how to reproduce the problem (which node to drag and where to drag it).

Oohh.....It could be that you've accidentally drawn a path with an LPE applied to it.  In that case, sometimes the path doesn't show up at all, whether you're dragging nodes or not.  You can find out if the path has an LPE by selecting with Selection tool ( :sel: ) and looking at the status bar.  The status bar will indicate "path effect".  If you see that, then you can do Path menu > Remove Path Effects (at the very bottom of the menu).

"Cusp node to cusp node" is probably the snap indicator.  Once you learn how to use snapping, you'll probably (well, at least might) want the indicator to be functioning.  So for now, you can just disable snapping.  In the toolbar along the right side of the window, the top button enables and disables snapping globally.  However, if you do want to turn off the indicator, it's at Inkscape Preferences > Behavior > Snapping and uncheck Enable Snap Indicator.


  • Inkscape version 0.92.3
  • Windows 7 Pro, 64-bit
Inkscape Tutorials (and manuals)                      Inkscape Community Gallery                        Inkscape for Cutting Design                     



"Be ashamed to die until you have won some victory for humanity" - Horace Mann                       

September 16, 2018, 01:35:26 PM
Reply #2

Moini

  • IC Mentor

  • Offline
  • ******

  • 1,047
    • VektorRascheln
Select the path and remove the path effect from it:

Path > Remove Path effects

Then you will have a normal path that will change as you change the nodes.

To avoid creating a path with a path effect from the start, make sure that for the Pencil and the Bézier tool, the 'Shape' at the top is set to 'None'.

September 17, 2018, 09:42:16 AM
Reply #3

lindamac1158

  • Sr. Newbie

  • Offline
  • **

  • 2
Wow, thank you so much Brynn and Moini. Everything has been fixed so I can enjoy Inkscape again.
  • 92.3
  • Windows 10