Author Topic: wacom tablet, pressure sensitivity works in gimp but not in inkscape  (Read 5883 times)

October 09, 2017, 08:38:51 PM
Read 5883 times

gjrussell

  • Newbie

  • Offline
  • *

  • 1
The subject says it all ... I have the "Use pressure sensitive tablet" box ticked.  In ubuntu 16.04.3 LTS and Inkscape 0.91 r13725

Any ideas gladly appreciated.
  • 0.91
  • Ubuntu 16.04.3 LTS

October 10, 2017, 01:13:24 AM
Reply #1

brynn

  • Administrator

  • Offline
  • ******

  • 3,939
  • Gender
    Female

    Female
    • Inkscape Community
Welcome to the forum!

I'm not a tablet user, so I can only point you to the settings in Inkscape.  Also, I see this problem posted a lot, but eventually it becomes resolved, and people say they don't know what they did, but it started working.  I'm thinking possibly everything needs to be restarted  (Inkscape and tablet, maybe even computer)??

Edit menu > Input Devices
Inkscape Preferences > Input/Output > Input Devices > the last 2 settings there
  • Inkscape version 0.92.3
  • Windows 7 Pro, 64-bit
Inkscape Tutorials (and manuals)                      Inkscape Community Gallery                        Inkscape for Cutting Design                     



"Be ashamed to die until you have won some victory for humanity" - Horace Mann                       

January 05, 2018, 04:42:38 PM
Reply #2

unclevinny

  • Newbie

  • Offline
  • *

  • 1
I found a solution that works for me.
I'm using Windows 10, Inkscape version 0.92.2 and an Intuos3 tablet.

First I confirmed that my Intuos3 had the latest driver.
Then opened Wacom Tablet Properties -> About -> Diagnose and confirmed that the Pressure readout increased above 0% when I used the pen on the tablet. All good!
Next I installed Gimp, confirmed that pressure sensitivity was being rec'd by Gimp.
Then in Inkscape, click Edit -> Input Devices and notice that only "Core Pointer" is being shown. I did some Googling on this, and found the missing link:
In Inkscape -> Edit -> Preferences -> Input/Output -> Input Devices, check the "Switch tool based on tablet device". ("Use pressure-sensitive tablet" was already checked for me.)
Go back to the Input Devices sidebar, click on each of "WACOM Tablet", "WACOM Tablet Eraser" and "WACOM Tablet Pressure Stylus" and be sure each is set to Mode=Screen

After this, pressure sensitivity worked for me immediately, but I suppose you may want to restart. I also found there's not advantage to starting Inkscape with the tablet; starting with the mouse works fine!

Cheers,
Uncle Vinny
  • 9.2
  • Win 10

January 06, 2018, 02:49:58 PM
Reply #3

brynn

  • Administrator

  • Offline
  • ******

  • 3,939
  • Gender
    Female

    Female
    • Inkscape Community
Welcome Uncle Vinny!

Thanks for sharing!  I always feel helpless when I see this kind of message, so I'll try to save this message, so I can find it the next time I see a similar problem.
  • Inkscape version 0.92.3
  • Windows 7 Pro, 64-bit
Inkscape Tutorials (and manuals)                      Inkscape Community Gallery                        Inkscape for Cutting Design                     



"Be ashamed to die until you have won some victory for humanity" - Horace Mann